使用pytorch.org上的安装指南介绍如何安装它,我使用的命令是

pip install torch===1.4.0 torchvision===0.5.0 -f https://download.pytorch.org/whl/torch_stable.html

但它出现了这个错误;

错误:找不到满足要求的版本===1.4.0(来自版本:0.1.2、0.1.2.post1、0.1.2.post2)

错误:未找到火炬===1.4.0的匹配分布

这是不是跟我有关?其他人可以使用这个命令吗?

Pip已安装并可用于其他模块,如Python 3.8、CUDA 10.1版、Windows 10 Home 2004

推荐答案

看起来这个问题与虚拟环境有关.您是否在另一个/新的虚拟环境中try 了推荐的安装线?如果没有帮助,可能的解决方案可能是使用Pytork和TorchVision系统构建的直接链接安装软件包:

pip install https://download.pytorch.org/whl/cu101/torch-1.4.0-cp38-cp38-win_amd64.whl

pip install https://download.pytorch.org/whl/cu101/torchvision-0.5.0-cp38-cp38-win_amd64.whl

Python-3.x相关问答推荐

总结基于条件的值,如果不匹配则保留当前值

正则表达式:匹配字符串中的分隔符(字母和特殊字符)以形成新的子字符串

非拉丁字符的Python正则表达式不起作用

pymongo 失败并出现错误“未定义”

ImportError:无法从“jinja2”导入名称“escape”

如何准确测定cv2的结果.在BW/黑白图像中查找对象?

如何在 VSCode 的“在 Cloud Run Emulator 上运行/调试”构建设置中添加 SQL 连接

通过 requests 库调用 API 获取访问令牌

使用一周的特定第一天将每日日期转换为每周

是否将dict转换为一个数据帧,每个值都有重复的键?

如何将数据框中的每一行转换为具有属性的节点?

为什么 pip3 在 Ubuntu 20.04 上安装/更新软件包后要创建一个 kdewallet?

在 macbook pro M1 上安装 Tensorflow 时出现“zsh:非法硬件指令 python”

在带有 M1 芯片(基于 ARM 的 Apple Silicon)的 Mac 上安装较早版本的 Python(3.8 之前)失败

如何从字典中打印特定键值?

如何将 Matplotlib 图形转换为 PIL Image 对象(不保存图像)

Generic[T] 基类 - 如何从实例中获取 T 的类型?

“with”语句是否支持类型提示?

安装 PyTorch 1.4 的问题 - “没有找到与 torch===1.4.0 匹配的发行版”

RuntimeError:输入类型(torch.FloatTensor)和权重类型(torch.cuda.FloatTensor)应该相同