Matplotlib - 环境设置介绍 首页MatplotlibMatplotlib - 环境设置

Matplotlib及其依赖软件包以标准Python软件包存储库中,可以使用pip命令安装。

pip3 install matplotlib

如果您在Mac上使用Python 2.7,请执行以下命令-

xcode-select install

Matplotlib需要大量的依赖关系-

  • Python (>= 2.7 or >= 3.4)
  • NumPy
  • setuptools
  • dateutil
  • pyparsing
  • libpng
  • pytz
  • FreeType
  • cycler
  • six

(可选)您还可以安装许多软件包以启用更好的用户界面工具包。

  • tk
  • PyQt4
  • PyQt5
  • pygtk
  • wxpython
  • pycairo
  • Tornado

为了更好地支持动画输出格式和图像文件格式,LaTeX等,可以安装以下内容-

  • _mpeg/avconv
  • ImageMagick
  • Pillow (>=2.0)
  • LaTeX and GhostScript (for rendering text with LaTeX).

这一章你学到了什么?做个笔记,好记忆不如烂笔头! 请将遇到的问题写入评论区中,大家一起进步。

祝学习愉快!(您也可以 选中需要修改的内容->右键->进行编辑)

点我分享笔记